Download

Download

The Moodle for NZ Schools edition is a customised version of the Moodle code base. New versions of NZ Schools edition are available for download below.

Moodle 2.8 for NZ Schools

The Moodle in NZ Schools 2.8 version is based on Moodle 2.8 and includes the customisations and additional modules that are available in the Moodle in NZ Schools Moodle 2.0 version and the integration between Moodle and Google that were introduced in Moodle in NZ Schools 2.2. The calendar import is now part of Moodle core.

Please refer to the site administrator notes for more information.

Please consult to the Moodle 2.8 release notes for information on new features in standard Moodle.

Requirements:

  • Minimum browser: Google Chrome 30, Firefox 25, Safari 6, Internet Explorer 9 (IE 10 required for drag and drop of files from outside the browser into Moodle)
  • Moodle upgrade: Moodle 2.2 or later (if upgrading from earlier versions, you must upgrade to 2.2.11 as a first step)
  • Minimum DB versions: Postgres 9.1, MySQL 5.5.31, Microsoft SQL Server 2008, or Oracle 10.2
  • Minimum PHP version: PHP 5.4.4, with GD extension.

NOTE: Moodle HQ has dropped support for Internet Explorer 8.

Moodle HQ has also published upgrade notes that should be consulted prior to an upgrade.

Release date: 
Fri, 13/02/2015

Previous releases

Moodle 2.7 for NZ schools

The Moodle in NZ Schools 2.7 version is based on Moodle 2.7 and includes the customisations and additional modules that are available in the Moodle in NZ Schools Moodle 2.0 version and the integration between Moodle and Google that were introduced in Moodle in NZ Schools 2.2. The calendar import is now part of Moodle core.

Please refer to the site administrator notes for more information.

Please consult to the Moodle 2.7 release notes for information on new features in standard Moodle.

Requirements:

  • Recommended minimum browser: recent Google Chrome, recent Mozilla Firefox, Safari 6, Internet Explorer 9 (IE 10 required for drag and drop of files from outside the browser into Moodle)
  • Moodle upgrade: Moodle 2.2 or later (if upgrading from earlier versions, you must upgrade to 2.2.11 as a first step)
  • Minimum DB versions: PostgreSQL 9.1, MySQL 5.5.31, MariaDB 5.5.31, MSSQL 2008 or Oracle 10.2
  • Minimum PHP version: PHP 5.4.4 (always use latest PHP 5.4.x or 5.5.x on Windows - http://windows.php.net/download/)

2.7 is a long term support version from moodle and so will recieve fixes for 3 years instead of the usual 1.5

Moodle HQ has also published upgrade notes that should be consulted prior to an upgrade.

Release date: 
Fri, 13/02/2015

Moodle 2.6 for NZ Schools

The Moodle in NZ Schools 2.6 version is based on Moodle 2.6 and includes the customisations and additional modules that are available in the Moodle in NZ Schools Moodle 2.0 version and the integration between Moodle and Google that were introduced in Moodle in NZ Schools 2.2. The calendar import is now part of Moodle core.

Please refer to the site administrator notes for more information.

Please consult to the Moodle 2.6 release notes for information on new features in standard Moodle.

Requirements:

  • Recommended minimum browser: recent Google Chrome, recent Mozilla Firefox, Safari 6, Internet Explorer 9 (IE 10 required for drag and drop of files from outside the browser into Moodle)
  • Moodle upgrade: Moodle 2.2 or later (if upgrading from earlier versions, you must upgrade to 2.2.11 as a first step)
  • Minimum DB versions: PostgreSQL 8.3, MySQL 5.1.33, MariaDB 5.3.5, MSSQL 2005 or Oracle 10.2
  • Minimum PHP version: PHP 5.3.3 (always use latest PHP 5.4.x or 5.5.x on Windows - http://windows.php.net/download/)
  • New recommended PHP extensions: zlib, OPcache

Moodle HQ has also published upgrade notes that should be consulted prior to an upgrade.

Release date: 
Fri, 13/02/2015

Moodle 2.5 for NZ Schools

 

The Moodle in NZ Schools 2.5 version is based on Moodle 2.5 and includes the customisations and additional modules that are available in the Moodle in NZ Schools Moodle 2.0 version and the integration between Moodle and Google that were introduced in Moodle in NZ Schools 2.2. The calendar import is now part of Moodle core.

Please refer to the site administrator notes for more information.

Please consult to the Moodle 2.5 release notes for information on new features in standard Moodle.

Requirements:

  • Minimum browser: Google Chrome 11, Firefox 4, Safari 5, Internet Explorer 8 (IE 10 required for drag and drop of files from outside the browser into Moodle)
  • Moodle upgrade: Moodle 2.2 or later (if upgrading from earlier versions, you must upgrade to 2.2.9 as a first step)
  • Minimum DB versions: Postgres 8.3, MySQL 5.1.33 (MDL-33984), MSSQL 2005 or Oracle 10.2
  • Minimum PHP version: PHP 5.3.3, with GD extension.

NOTE: Moodle HQ will drop support for IE8 in Moodle 2.6 (to be released November 2013).

Moodle HQ has also published upgrade notes that should be consulted prior to an upgrade.

 

Release date: 
Wed, 26/11/2014

Moodle 2.4 for NZ Schools

The Moodle in NZ Schools 2.4 version is based on Moodle 2.4 and includes the customisations and additional modules that are available in the Moodle in NZ Schools Moodle 2.0 version and the integration between Moodle and Google that were introduced in Moodle in NZ Schools 2.2. The calendar import is now part of Moodle core.

Please refer to the site administrator notes for more information.

Please consult to the Moodle 2.4 release notes for information on new features in standard Moodle.

Requirements:

  • Minimum browser: Firefox 4, Internet Explorer 8, Safari 5, Google Chrome 11
  • Moodle upgrade: Moodle 2.2 or later (if upgrading from earlier versions, you must upgrade to 2.2 as a first step)
  • Minimum DB versions: Postgres 8.3, MySQL 5.1.33 (MDL-33984), MSSQL 2005 or Oracle 10.2
  • Minimum PHP version: PHP 5.3.2

NOTE: Moodle HQ will probably drop support for IE8 in Moodle 2.5 (June 2013).

Moodle HQ has also published upgrade notes that should be consulted prior to an upgrade.

Release date: 
Mon, 28/07/2014

Moodle 2.3 for NZ Schools

The Moodle in NZ Schools 2.3 version is based on Moodle 2.3 and includes the customizations and additional modules that are available in the Moodle in NZ Schools Moodle 2.0 version and the integration between Moodle and Google that were introduced in Moodle in NZ Schools 2.2.

 

Please refer to the site administrator notes for more information.

Please consult to the Moodle 2.3 release notes for information on new features in standard Moodle.

Requirements:

  • Minimum browser: Firefox 4, Internet Explorer 8, Safari 5, Google Chrome 11, Opera 9
  • Moodle upgrade: Moodle 2.2 or later (if upgrading from earlier versions, you must upgrade to 2.2 as a first step)
  • Minimum DB versions: Postgres 8.3, MySQL 5.1.33 (MDL-33984), MSSQL 2005 or Oracle 10.2
  • Minimum PHP version: PHP 5.3.2

 

Moodle HQ has also published upgrade notes that should be consulted prior to an upgrade.

Release date: 
Mon, 13/01/2014